+ Antworten
Seite 1 von 2 1 2 LetzteLetzte
Ergebnis 1 bis 10 von 12
  1. #1
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    2,110

    Question php_imap.dll geladen oder nicht

    Hallo
    Wollte heute mal zum testen die Extension php_imap.dll aktivieren.
    php_imap.dll ins ext Verzeichniss kopiert und Dienst neu gestartet.
    Im Logfile steht.
    PHP-Code:
    17.04.2012 12:35:38.546 |     MESSAGE ScriptEngine         Erstelle...
    17.04.2012 12:35:38.562 |     MESSAGE ScriptEngine         Benutze PHP 5.4.0
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >OpenSSL #1: 1.0.0
    17.04.2012 12:35:38.640 |     MESSAGE ScriptEngine         | >OpenSSL #1: 1.0.0
    17.04.2012 12:35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_curl.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_gd2.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_gettext.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_imap.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_mbstring.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_mysql.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE ScriptEngine         | >Erweiterungphp_soap.dll
    17.04.2012 12
    :35:38.640 |     MESSAGE LicensePool          Version10.02.12#2252 
    Aufruf von imap_open() erbringt.
    PHP-Code:
    Fatal error:  Call to undefined function imap_open() in 
    auch phpinfo() bringt keinen Hinweis auf imap Extension.
    Hat jemand eine Idee ?

  2. #2
    Registriert seit
    Apr 2010
    Ort
    Oberbayern
    Beiträge
    3,641

    Was sagt denn die php.ini? Hat IPS die Extension da eingetragen? Wenn nein hat er Sie eher mal nicht geladen.
    Grüsse, Kronos.
    Wenn am Anfang alles schief geht, nenne es Version 1.0
    IPS 3.2 auf 2008R2 / HM / CCU2+LAN-Adapter / XBee Pro (Roomba+eDIP+Arduino) / RGB-W 868 / EKM 868 / AKM / Squeezeboxen+Pi / EM24DIN+VS102 / AM 220 AC / PlugWise / VU+ / ALL4xxx / LevelJet / zu wenig Zeit

  3. #3
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    2,110

    Ist eingetragen

  4. #4
    Registriert seit
    Apr 2010
    Ort
    Oberbayern
    Beiträge
    3,641

    Dann sollte er sie eigentlich auch geladen haben. In der LOG-Datei sieht es ja auch gut aus.

    Nur sicherheitshalber - meine DLL ist die 5.4.0RC3 mit 814.592 Bytes vom 19.3.2012.
    Grüsse, Kronos.
    Wenn am Anfang alles schief geht, nenne es Version 1.0
    IPS 3.2 auf 2008R2 / HM / CCU2+LAN-Adapter / XBee Pro (Roomba+eDIP+Arduino) / RGB-W 868 / EKM 868 / AKM / Squeezeboxen+Pi / EM24DIN+VS102 / AM 220 AC / PlugWise / VU+ / ALL4xxx / LevelJet / zu wenig Zeit

  5. #5
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    2,110

    Danke das wars.
    Ist zwar auch 5.4.0 gewesen aber falsches Paket.
    Man sollte lesen aus welchem Paket man die Extension holt.
    Hab die vom "Non Thread Safe" genommen.

  6. #6
    Registriert seit
    Apr 2010
    Ort
    Oberbayern
    Beiträge
    3,641

    Hmh, komisch eigentlich. IPS sollte die Extensions ab 2.5 doch selbst auf dem Stand halten. Oder das Liveupdate prüft nur die Versionsnummer.
    Grüsse, Kronos.
    Wenn am Anfang alles schief geht, nenne es Version 1.0
    IPS 3.2 auf 2008R2 / HM / CCU2+LAN-Adapter / XBee Pro (Roomba+eDIP+Arduino) / RGB-W 868 / EKM 868 / AKM / Squeezeboxen+Pi / EM24DIN+VS102 / AM 220 AC / PlugWise / VU+ / ALL4xxx / LevelJet / zu wenig Zeit

  7. #7
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    2,110

    Zur Info.
    Hab kein Liveupdate gemacht nach dem kopieren der Extension.
    Ein Liveupdate hat das Problem beseitigt.

  8. #8
    Registriert seit
    Apr 2010
    Ort
    Oberbayern
    Beiträge
    3,641

    Ok, dann hat das ja seine Richtigkeit. Am besten immer nachdem man eine Extension rein kopiert hat ein Live-Update machen.
    Grüsse, Kronos.
    Wenn am Anfang alles schief geht, nenne es Version 1.0
    IPS 3.2 auf 2008R2 / HM / CCU2+LAN-Adapter / XBee Pro (Roomba+eDIP+Arduino) / RGB-W 868 / EKM 868 / AKM / Squeezeboxen+Pi / EM24DIN+VS102 / AM 220 AC / PlugWise / VU+ / ALL4xxx / LevelJet / zu wenig Zeit

  9. #9
    Registriert seit
    Mar 2008
    Ort
    Ruesselsheim
    Beiträge
    2,110

    Es geht auch so.
    Wenn man ein Extension braucht die man nicht hat.
    Mit einem Texteditor eine Datei erstellen mit dem Namen der Extension.
    Sie muss mindestens 1 Byte haben.
    Und dann ein Liveupdate machen.
    Man lernt nie aus.

  10. #10
    Registriert seit
    Dec 2010
    Beiträge
    89

    Hallo zusammen,

    ich habe den gleichen Fehler auf der Version 2.5. wie oben beschrieben. Kann auch keinen IMAP Stream öffnen, da IPS die Funktion nicht geladen hat. Die php_imap.dll ist im Extension Ordner und in der php.ini ist sie auch deklariert.

    Wo bekomme ich die aktuelle Version her? Ich kann leider kein liveupdate machen, da meine Subscription abgelaufen ist.

    Gruß

Ähnliche Themen

  1. Bild wird nicht aktualisiert
    Von honk0504 im Forum WebFront
    Antworten: 14
    Letzter Beitrag: 09.01.12, 18:30
  2. PHP extensions werden nicht geladen
    Von BestEx im Forum Skripte, PHP, SQL
    Antworten: 7
    Letzter Beitrag: 15.12.11, 22:37
  3. ToniTools(.dll) wird nicht geladen
    Von obicom im Forum Allgemeine Diskussion
    Antworten: 4
    Letzter Beitrag: 28.07.09, 19:06
  4. Formular kann nicht über Internet geladen werden
    Von Schilflaus im Forum Dashboard
    Antworten: 0
    Letzter Beitrag: 04.12.06, 10:58